What’s Vulnerable › Vulnerabilities
CVE-2025-31696: RapiDoc OAS Field Formatter - Moderately critical - Cross site scripting - SA-CONTRIB-2025-025
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-31 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal RapiDoc OAS Field Formatter allows Cross-Site Scripting (XSS).This issue affects RapiDoc OAS Field Formatter: from 0.0.0 before 1.0.1.
Affected products
- Drupal RapiDoc OAS Field Formatter: before 1.0.1 — fixed in 1.0.1
How to fix
Upgrade to a fixed version: Drupal RapiDoc OAS Field Formatter 1.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-31696 or the next vulnerability affects your stack