What’s Vulnerable › Vulnerabilities
CVE-2025-31697: Formatter Suite - Moderately critical - Cross site scripting - SA-CONTRIB-2025-026
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-31 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Formatter Suite allows Cross-Site Scripting (XSS).This issue affects Formatter Suite: from 0.0.0 before 2.1.0.
Affected products
- Drupal Formatter Suite: before 2.1.0 — fixed in 2.1.0
How to fix
Upgrade to a fixed version: Drupal Formatter Suite 2.1.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-31697 or the next vulnerability affects your stack