What’s Vulnerable › Vulnerabilities
CVE-2025-31722
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-02 · updated 2026-06-17
- Weakness: CWE-94
Description
In Jenkins Templating Engine Plugin 2.5.3 and earlier, libraries defined in folders are not subject to sandbox protection, allowing attackers with Item/Configure permission to execute arbitrary code in the context of the Jenkins controller JVM.
Affected products
- Jenkins Project Jenkins Templating Engine Plugin: before 2.5.4 — fixed in 2.5.4
How to fix
Upgrade to a fixed version: Jenkins Project Jenkins Templating Engine Plugin 2.5.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-31722 or the next vulnerability affects your stack