What’s Vulnerable › Vulnerabilities
CVE-2025-3189: Stored Cross-Site Scripting (XSS) in DoWISP
- Severity: medium (CVSS 4.8 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-04 · updated 2026-06-17
- Weakness: CWE-78
Description
Stored Cross-Site Scripting (XSS) in DoWISP in versions prior to 1.16.2.50, which consists of an stored XSS through the upload of a profile picture in SVG format with malicious Javascript code in it.
Affected products
- DoWISP: before 1.16.2.50 — fixed in 1.16.2.50
How to fix
Upgrade to a fixed version: DoWISP 1.16.2.50. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-3189 or the next vulnerability affects your stack