What’s Vulnerable › Vulnerabilities
CVE-2025-31910: WordPress BookingPress plugin <= 1.1.28 - SQL Injection vulnerability
- Severity: high (CVSS 7.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-01 · updated 2026-06-17
- Weakness: CWE-89
Description
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in reputeinfosystems BookingPress bookingpress-appointment-booking allows SQL Injection.This issue affects BookingPress: from n/a through <= 1.1.28.
Affected products
- reputeinfosystems Appointment Booking Calendar Plugin and Scheduling Plugin – BookingPress: before 1.1.38 — fixed in 1.1.38
How to fix
Upgrade to a fixed version: reputeinfosystems Appointment Booking Calendar Plugin and Scheduling Plugin – BookingPress 1.1.38. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-31910 or the next vulnerability affects your stack