What’s Vulnerable › Vulnerabilities
CVE-2025-3193
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-09-27 · updated 2026-10-19
- Weakness: CWE-1321
Description
Versions of the package algoliasearch-helper from 2.0.0-rc1 and before 3.11.2 are vulnerable to Prototype Pollution in the _merge() function in merge.js, which allows constructor.prototype to be written even though doing so throws an error. In the "extreme edge-case" that the resulting error is caught, code injected into the user-supplied search parameter may be exeucted. This is related to but distinct from the issue reported in [CVE-2021-23433](https://security.snyk.io/vuln/SNYK-JS-ALGOLIASEARCHHELPER-1570421). **NOTE:** This vulnerability is not exploitable in the default configuration of InstantSearch since searchParameters are not modifiable by users.
Affected products
- algoliasearch-helper: from 2.0.0 before 3.11.2 — fixed in 3.11.2
How to fix
Upgrade to a fixed version: algoliasearch-helper 3.11.2. Check the vendor advisory for mitigations.
References
- https://github.com/algolia/algoliasearch-helper-js/commit/776dff23c87b0902e554e02a8c2567d2580fe12a
- https://github.com/algolia/algoliasearch-helper-js/issues/922
- https://security.snyk.io/vuln/SNYK-JS-ALGOLIASEARCHHELPER-3318396
Get alerted when CVE-2025-3193 or the next vulnerability affects your stack