What’s Vulnerable › Vulnerabilities
CVE-2025-3199: ageerle ruoyi-ai API Interface SysModelController.java improper authorization
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-04-04 · updated 2026-06-17
- Weakness: CWE-266
Description
A vulnerability was found in ageerle ruoyi-ai up to 2.0.1 and classified as critical. Affected by this issue is some unknown functionality of the file ruoyi-modules/ruoyi-system/src/main/java/org/ruoyi/system/controller/system/SysModelController.java of the component API Interface. The manipulation leads to improper authorization. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.2 is able to address this issue. The name of the patch is c0daf641fb25b244591b7a6c3affa35c69d321fe. It is recommended to upgrade the affected component.
Affected products
- Pandarobot Ruoyi Ai: before 2.0.2 — fixed in 2.0.2
How to fix
Upgrade to a fixed version: Pandarobot Ruoyi Ai 2.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/Tr0e/CVE_Hunter/blob/main/ruoyi-ai/ruoyi-ai_UnauthorizedAccess_01.md
- https://github.com/ageerle/ruoyi-ai/issues/43
- https://github.com/ageerle/ruoyi-ai/issues/43#issuecomment-2763091490
- https://github.com/ageerle/ruoyi-ai/releases/tag/v2.0.2
- https://github.com/gwozai/ruoyi-ai/commit/c0daf641fb25b244591b7a6c3affa35c69d321fe
- https://vuldb.com/?ctiid.303152
- https://vuldb.com/?id.303152
- https://vuldb.com/?submit.545830
- https://github.com/Tr0e/CVE_Hunter/blob/main/ruoyi-ai/ruoyi-ai_UnauthorizedAccess_01.md
Get alerted when CVE-2025-3199 or the next vulnerability affects your stack