What’s Vulnerable › Vulnerabilities
CVE-2025-3200: Com-Server Exposed via Weak TLS
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-28 · updated 2026-06-17
- Weakness: CWE-327
Description
An unauthenticated remote attacker could exploit the used, insecure TLS 1.0 and TLS 1.1 protocols to intercept and manipulate encrypted communications between the Com-Server and connected systems.
Affected products
- Wiesemann & Theis Com-Server++: before 1.60 — fixed in 1.60
- Wiesemann & Theis Com-Server 20mA: before 1.60 — fixed in 1.60
- Wiesemann & Theis Com-Server OEM: before 1.60 — fixed in 1.60
- Wiesemann & Theis Com-Server PoE 3x Isolated: before 1.60 — fixed in 1.60
- Wiesemann & Theis Com-Server UL: before 1.60 — fixed in 1.60
How to fix
Upgrade to a fixed version: Wiesemann & Theis Com-Server++ 1.60; Wiesemann & Theis Com-Server 20mA 1.60; Wiesemann & Theis Com-Server OEM 1.60; Wiesemann & Theis Com-Server PoE 3x Isolated 1.60; Wiesemann & Theis Com-Server UL 1.60. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-3200 or the next vulnerability affects your stack