What’s Vulnerable › Vulnerabilities
CVE-2025-32015: FreshRSS vulnerable to Cross-site Scripting by embedding <script> tag inside <iframe srcdoc>
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-04 · updated 2026-06-17
- Weakness: CWE-79
Description
FreshRSS is a self-hosted RSS feed aggregator. Prior to version 1.26.2, HTML is sanitized improperly inside the `<iframe srcdoc>` attribute, which leads to cross-site scripting (XSS) by loading an attacker's UserJS inside `<script src>`. In order to execute the attack, the attacker needs to control one of the victim's feeds and have an account on the FreshRSS instance that the victim is using. An attacker can gain access to the victim's account by exploiting this vulnerability. If the victim is an admin it would be possible to delete all users (cause damage) or execute arbitrary code on the server by modifying the update URL using fetch() via the XSS. Version 1.26.2 contains a patch for the issue.
Affected products
- FreshRSS: before 1.26.2 — fixed in 1.26.2
How to fix
Upgrade to a fixed version: FreshRSS 1.26.2. Check the vendor advisory for mitigations.
References
- https://github.com/FreshRSS/FreshRSS/commit/54e2f9107d03c5b3bb260f38fdb2736bce449fd4
- https://github.com/FreshRSS/FreshRSS/security/advisories/GHSA-wgrq-mcwc-8f8v
Get alerted when CVE-2025-32015 or the next vulnerability affects your stack