What’s Vulnerable › Vulnerabilities
CVE-2025-32017: Umbraco has a Management API Vulnerability to Path Traversal With Authenticated Users
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-08 · updated 2026-06-17
- Weakness: CWE-23
Description
Umbraco is a free and open source .NET content management system. Authenticated users to the Umbraco backoffice are able to craft management API request that exploit a path traversal vulnerability to upload files into a incorrect location. The issue affects Umbraco 14+ and is patched in 14.3.4 and 15.3.1.
Affected products
- Umbraco-CMS: from 14.0.0 before 14.3.4; from 15.0.0 before 15.3.1 — fixed in 14.3.4, 15.3.1
How to fix
Upgrade to a fixed version: Umbraco-CMS 14.3.4, 15.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/umbraco/Umbraco-CMS/commit/06a2a500b358ce15b1e228391eb60bd517c6e833
- https://github.com/umbraco/Umbraco-CMS/commit/d3c1443b14b1076faf13d1bcecc42860fdf5fad8
- https://github.com/umbraco/Umbraco-CMS/security/advisories/GHSA-q62r-8ppj-xvf4
Get alerted when CVE-2025-32017 or the next vulnerability affects your stack