What’s Vulnerable › Vulnerabilities
CVE-2025-3202: ageerle ruoyi-ai SysNoticeController.java improper authorization
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-04-04 · updated 2026-06-17
- Weakness: CWE-266
Description
A vulnerability classified as critical has been found in ageerle ruoyi-ai up to 2.0.0. Affected is an unknown function of the file ruoyi-modules/ruoyi-system/src/main/java/org/ruoyi/system/controller/system/SysNoticeController.java. The manipulation leads to improper authorization. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.1 is able to address this issue. The name of the patch is 6382e177bf90cc56ff70521842409e35c50df32d. It is recommended to upgrade the affected component.
Affected products
- ageerle ruoyi-ai: before 2.0.1 — fixed in 2.0.1
How to fix
Upgrade to a fixed version: ageerle ruoyi-ai 2.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/Tr0e/CVE_Hunter/blob/main/ruoyi-ai/ruoyi-ai_UnauthorizedAccess_02.md
- https://github.com/ageerle/ruoyi-ai/commit/6382e177bf90cc56ff70521842409e35c50df32d
- https://github.com/ageerle/ruoyi-ai/issues/44#issue-2957771318
- https://github.com/ageerle/ruoyi-ai/releases/tag/v2.0.1
- https://vuldb.com/?ctiid.303156
- https://vuldb.com/?id.303156
- https://vuldb.com/?submit.545866
- https://github.com/Tr0e/CVE_Hunter/blob/main/ruoyi-ai/ruoyi-ai_UnauthorizedAccess_02.md
Get alerted when CVE-2025-3202 or the next vulnerability affects your stack