What’s Vulnerable › Vulnerabilities
CVE-2025-32023: Redis allows out of bounds writes in hyperloglog commands leading to RCE
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-07 · updated 2026-06-17
- Weakness: CWE-680
Description
Redis is an open source, in-memory database that persists on disk. From 2.8 to before 8.0.3, 7.4.5, 7.2.10, and 6.2.19, an authenticated user may use a specially crafted string to trigger a stack/heap out of bounds write on hyperloglog operations, potentially leading to remote code execution. The bug likely affects all Redis versions with hyperloglog operations implemented. This vulnerability is fixed in 8.0.3, 7.4.5, 7.2.10, and 6.2.19. An additional workaround to mitigate the problem without patching the redis-server executable is to prevent users from executing hyperloglog operations. This can be done using ACL to restrict HLL commands.
Affected products
- Redis: from 2.8.0 before 6.2.19; from 7.2.0 before 7.2.10; from 7.4.0 before 7.4.5; from 8.0.0 before 8.0.3 — fixed in 6.2.19, 7.2.10, 7.4.5, 8.0.3
How to fix
Upgrade to a fixed version: Redis 6.2.19, 7.2.10, 7.4.5, 8.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/redis/redis/commit/50188747cbfe43528d2719399a2a3c9599169445
- https://github.com/redis/redis/releases/tag/6.2.19
- https://github.com/redis/redis/releases/tag/7.2.10
- https://github.com/redis/redis/releases/tag/7.4.5
- https://github.com/redis/redis/releases/tag/8.0.3
- https://github.com/redis/redis/security/advisories/GHSA-rp2m-q4j6-gr43
- https://www.exploit-db.com/exploits/52477
Get alerted when CVE-2025-32023 or the next vulnerability affects your stack