What’s Vulnerable › Vulnerabilities
CVE-2025-32027: Yii does not prevent XSS in scenarios where fallback error renderer is used
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-10 · updated 2026-06-17
- Weakness: CWE-79
Description
Yii is an open source PHP web framework. Prior to 1.1.31, yiisoft/yii is vulnerable to Reflected XSS in specific scenarios where the fallback error renderer is used. Upgrade yiisoft/yii to version 1.1.31 or higher.
Affected products
- yiisoft yii: before 1.1.31 — fixed in 1.1.31
How to fix
Upgrade to a fixed version: yiisoft yii 1.1.31. Check the vendor advisory for mitigations.
References
- https://github.com/yiisoft/yii/commit/d386d737861c9014269b7ed8c36c65eadb387368
- https://github.com/yiisoft/yii/security/advisories/GHSA-7r2v-8wxr-3ch5
Get alerted when CVE-2025-32027 or the next vulnerability affects your stack