What’s Vulnerable › Vulnerabilities
CVE-2025-32030: Apollo Gateway Query Planner Vulnerable to Excessive Resource Consumption via Named Fragment Expansion
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-07 · updated 2026-06-17
- Weakness: CWE-770
Description
Apollo Gateway provides utilities for combining multiple GraphQL microservices into a single GraphQL endpoint. Prior to 2.10.1, a vulnerability in Apollo Gateway allowed queries with deeply nested and reused named fragments to be prohibitively expensive to query plan, specifically during named fragment expansion. Named fragments were being expanded once per fragment spread during query planning, leading to exponential resource usage when deeply nested and reused fragments were involved. This could lead to excessive resource consumption and denial of service. This has been remediated in @apollo/gateway version 2.10.1.
Affected products
- apollographql Apollo Gateway: before 2.10.1 — fixed in 2.10.1
How to fix
Upgrade to a fixed version: apollographql Apollo Gateway 2.10.1. Check the vendor advisory for mitigations.
References
- https://github.com/apollographql/federation/pull/3236
- https://github.com/apollographql/federation/releases/tag/%40apollo%2Fgateway%402.10.1
- https://github.com/apollographql/federation/security/advisories/GHSA-q2f9-x4p4-7xmh
Get alerted when CVE-2025-32030 or the next vulnerability affects your stack