What’s Vulnerable › Vulnerabilities
CVE-2025-32031: Apollo Gateway Query Planner Vulnerable to Excessive Resource Consumption via Optimization Bypass
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-07 · updated 2026-06-17
- Weakness: CWE-770
Description
Apollo Gateway provides utilities for combining multiple GraphQL microservices into a single GraphQL endpoint. Prior to 2.10.1, a vulnerability in Apollo Gateway allowed queries with deeply nested and reused named fragments to be prohibitively expensive to query plan, specifically due to internal optimizations being frequently bypassed. The query planner includes an optimization that significantly speeds up planning for applicable GraphQL selections. However, queries with deeply nested and reused named fragments can generate many selections where this optimization does not apply, leading to significantly longer planning times. Because the query planner does not enforce a timeout, a small number of such queries can render gateway inoperable. This could lead to excessive resource consumption and denial of service. This has been remediated in @apollo/gateway version 2.10.1.
Affected products
- apollographql Apollo Gateway: before 2.10.1 — fixed in 2.10.1
How to fix
Upgrade to a fixed version: apollographql Apollo Gateway 2.10.1. Check the vendor advisory for mitigations.
References
- https://github.com/apollographql/federation/pull/3236
- https://github.com/apollographql/federation/releases/tag/%40apollo%2Fgateway%402.10.1
- https://github.com/apollographql/federation/security/advisories/GHSA-p2q6-pwh5-m6jr
Get alerted when CVE-2025-32031 or the next vulnerability affects your stack