What’s Vulnerable › Vulnerabilities
CVE-2025-32044: Moodle: unauthenticated rest api user data exposure
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-25 · updated 2026-06-17
- Weakness: CWE-200
Description
A flaw has been identified in Moodle where, on certain sites, unauthenticated users could retrieve sensitive user data—including names, contact information, and hashed passwords—via stack traces returned by specific API calls. Sites with PHP configured with zend.exception_ignore_args = 1 in the php.ini file are not affected by this vulnerability.
Affected products
- Moodle: from 4.5.0 before 4.5.3 — fixed in 4.5.3
How to fix
Upgrade to a fixed version: Moodle 4.5.3. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2025-32044
- https://bugzilla.redhat.com/show_bug.cgi?id=2356829
Get alerted when CVE-2025-32044 or the next vulnerability affects your stack