What’s Vulnerable › Vulnerabilities
CVE-2025-32089: Dell ControlVault3 CvManager_SBI buffer overflow vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-17 · updated 2026-10-18
- Weakness: CWE-120
Description
A buffer overflow vulnerability exists in the CvManager_SBI functionality of Dell ControlVault3 prior to 5.15.14.19 and Dell ControlVault3 Plus prior to 6.2.36.47. A specially crafted ControlVault API call can lead to a arbitrary code execution. An attacker can issue an api call to trigger this vulnerability.
Affected products
- Broadcom BCM5820X: all versions
- Dell ControlVault3: before 5.15.14.19 — fixed in 5.15.14.19
- Dell ControlVault3 Plus: before 6.2.36.47 — fixed in 6.2.36.47
How to fix
Upgrade to a fixed version: Dell ControlVault3 5.15.14.19; Dell ControlVault3 Plus 6.2.36.47. Check the vendor advisory for mitigations.
References
- https://talosintelligence.com/vulnerability_reports/TALOS-2025-2188
- https://www.dell.com/support/kbdoc/en-us/000326061/dsa-2025-228
- https://www.talosintelligence.com/vulnerability_reports/TALOS-2025-2188
Get alerted when CVE-2025-32089 or the next vulnerability affects your stack