What’s Vulnerable › Vulnerabilities
CVE-2025-32352
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-05 · updated 2026-06-17
- Weakness: CWE-843
Description
A type confusion vulnerability in lib/NSSAuthenticator.php in ZendTo before v5.04-7 allows remote attackers to bypass authentication for users with passwords stored as MD5 hashes that can be interpreted as numbers. A solution requires moving from MD5 to bcrypt.
Affected products
- ZendTo: before 5.04-7 — fixed in 5.04-7
How to fix
Upgrade to a fixed version: ZendTo 5.04-7. Check the vendor advisory for mitigations.
References
- https://projectblack.io/blog/zendto-nday-vulnerabilities/
- https://projectblack.io/blog/zendto-nday-vulnerabilities/
Get alerted when CVE-2025-32352 or the next vulnerability affects your stack