What’s Vulnerable › Vulnerabilities
CVE-2025-32358
- Severity: medium (CVSS 4.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-05 · updated 2026-06-17
- Weakness: CWE-918
Description
In Zammad 6.4.x before 6.4.2, SSRF can occur. Authenticated admin users can enable webhooks in Zammad, which are triggered as POST requests when certain conditions are met. If a webhook endpoint returned a redirect response, Zammad would follow it automatically with another GET request. This could be abused by an attacker to cause GET requests for example in the local network.
Affected products
- zammad: from 6.4.0 before 6.4.2 — fixed in 6.4.2
How to fix
Upgrade to a fixed version: zammad 6.4.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-32358 or the next vulnerability affects your stack