What’s Vulnerable › Vulnerabilities
CVE-2025-32359
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-05 · updated 2026-06-17
- Weakness: CWE-602
Description
In Zammad 6.4.x before 6.4.2, there is client-side enforcement of server-side security. When changing their two factor authentication configuration, users need to re-authenticate with their current password first. However, this change was enforced in Zammad only on the front end level, and not when using the API directly.
Affected products
- zammad: from 6.4.0 before 6.4.2 — fixed in 6.4.2
How to fix
Upgrade to a fixed version: zammad 6.4.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-32359 or the next vulnerability affects your stack