What’s Vulnerable › Vulnerabilities
CVE-2025-32364
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-04-05 · updated 2026-06-17
- Weakness: CWE-190
Description
A floating-point exception in the PSStack::roll function of Poppler before 25.04.0 can cause an application to crash when handling malformed inputs associated with INT_MIN.
Affected products
- poppler: before 25.04.0 — fixed in 25.04.0
How to fix
Upgrade to a fixed version: poppler 25.04.0. Check the vendor advisory for mitigations.
References
- https://gitlab.freedesktop.org/poppler/poppler/-/commit/d87bc726c7cc98f8c26b60ece5f20236e9de1bc3
- https://gitlab.freedesktop.org/poppler/poppler/-/issues/1574
- https://lists.debian.org/debian-lts-announce/2025/04/msg00037.html
Get alerted when CVE-2025-32364 or the next vulnerability affects your stack