What’s Vulnerable › Vulnerabilities
CVE-2025-32365
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-04-05 · updated 2026-06-17
- Weakness: CWE-125
Description
Poppler before 25.04.0 allows crafted input files to trigger out-of-bounds reads in the JBIG2Bitmap::combine function in JBIG2Stream.cc because of a misplaced isOk check.
Affected products
- poppler: before 25.04.0 — fixed in 25.04.0
How to fix
Upgrade to a fixed version: poppler 25.04.0. Check the vendor advisory for mitigations.
References
- https://gitlab.freedesktop.org/poppler/poppler/-/issues/1577
- https://gitlab.freedesktop.org/poppler/poppler/-/merge_requests/1792
- https://lists.debian.org/debian-lts-announce/2025/04/msg00037.html
Get alerted when CVE-2025-32365 or the next vulnerability affects your stack