What’s Vulnerable › Vulnerabilities
CVE-2025-32404
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-07 · updated 2026-06-17
- Weakness: CWE-787
Description
An Out-of-bounds Write in RT-Labs P-Net version 1.0.1 or earlier allows an attacker to corrupt the memory of IO devices that use the library by sending a malicious RPC packet.
Affected products
- RT-Labs P-Net: before 1.0.2 — fixed in 1.0.2
How to fix
Upgrade to a fixed version: RT-Labs P-Net 1.0.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-32404 or the next vulnerability affects your stack