What’s Vulnerable › Vulnerabilities
CVE-2025-32414
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-04-08 · updated 2026-06-17
- Weakness: CWE-393
Description
In libxml2 before 2.13.8 and 2.14.x before 2.14.2, out-of-bounds memory access can occur in the Python API (Python bindings) because of an incorrect return value. This occurs in xmlPythonFileRead and xmlPythonFileReadRaw because of a difference between bytes and characters.
Affected products
- xmlsoft libxml2: before 2.13.8; from 2.14.0 before 2.14.2 — fixed in 2.13.8, 2.14.2
How to fix
Upgrade to a fixed version: xmlsoft libxml2 2.13.8, 2.14.2. Check the vendor advisory for mitigations.
References
- https://gitlab.gnome.org/GNOME/libxml2/-/issues/889
- https://lists.debian.org/debian-lts-announce/2025/04/msg00041.html
- https://gitlab.gnome.org/GNOME/libxml2/-/issues/889
Get alerted when CVE-2025-32414 or the next vulnerability affects your stack