What’s Vulnerable › Vulnerabilities
CVE-2025-32415
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-04-17 · updated 2026-06-17
- Weakness: CWE-1284
Description
In libxml2 before 2.13.8 and 2.14.x before 2.14.2, xmlSchemaIDCFillNodeTables in xmlschemas.c has a heap-based buffer under-read. To exploit this, a crafted XML document must be validated against an XML schema with certain identity constraints, or a crafted XML schema must be used.
Affected products
- xmlsoft libxml2: before 2.13.8; from 2.14.0 before 2.14.2 — fixed in 2.13.8, 2.14.2
How to fix
Upgrade to a fixed version: xmlsoft libxml2 2.13.8, 2.14.2. Check the vendor advisory for mitigations.
References
- https://gitlab.gnome.org/GNOME/libxml2/-/issues/890
- https://lists.debian.org/debian-lts-announce/2025/04/msg00041.html
- https://gitlab.gnome.org/GNOME/libxml2/-/issues/890
Get alerted when CVE-2025-32415 or the next vulnerability affects your stack