What’s Vulnerable › Vulnerabilities
CVE-2025-32421: Next.js Race Condition to Cache Poisoning
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-14 · updated 2026-06-17
- Weakness: CWE-362
Description
Next.js is a React framework for building full-stack web applications. Versions prior to 14.2.24 and 15.1.6 have a race-condition vulnerability. This issue only affects the Pages Router under certain misconfigurations, causing normal endpoints to serve `pageProps` data instead of standard HTML. This issue was patched in versions 15.1.6 and 14.2.24 by stripping the `x-now-route-matches` header from incoming requests. Applications hosted on Vercel's platform are not affected by this issue, as the platform does not cache responses based solely on `200 OK` status without explicit `cache-control` headers. Those who self-host Next.js deployments and are unable to upgrade immediately can mitigate this vulnerability by stripping the `x-now-route-matches` header from all incoming requests at the content development network and setting `cache-control: no-store` for all responses under risk. The maintainers of Next.js strongly recommend only caching responses with explicit cache-control headers.
Affected products
- Next.js: before 14.2.24; from 15.0.0 before 15.1.6 — fixed in 14.2.24, 15.1.6
- Npm Next: from 0.9.9 before 14.2.24; from 15.0.0 before 15.1.6 — fixed in 14.2.24, 15.1.6
How to fix
Upgrade to a fixed version: Next.js 14.2.24, 15.1.6; Npm Next 14.2.24, 15.1.6. Check the vendor advisory for mitigations.
References
- https://github.com/vercel/next.js/security/advisories/GHSA-qpjv-v59x-3qc4
- https://vercel.com/changelog/cve-2025-32421
Get alerted when CVE-2025-32421 or the next vulnerability affects your stack