What’s Vulnerable › Vulnerabilities
CVE-2025-32427: Formie has a XSS vulnerability for importing forms
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-11 · updated 2026-06-17
- Weakness: CWE-79
Description
Formie is a Craft CMS plugin for creating forms. Prior to 2.1.44, when importing a form from JSON, if the field label or handle contained malicious content, the output wasn't correctly escaped when viewing a preview of what was to be imported. As imports are undertaking primarily by users who have themselves exported the form from one environment to another, and would require direct manipulation of the JSON export, this is marked as moderate. This vulnerability will not occur unless someone deliberately tampers with the export. This vulnerability is fixed in 2.1.44.
Affected products
- verbb formie: before 2.1.44 — fixed in 2.1.44
How to fix
Upgrade to a fixed version: verbb formie 2.1.44. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-32427 or the next vulnerability affects your stack