What’s Vulnerable › Vulnerabilities
CVE-2025-32430: XWiki Platform contains Reflected XSS vulnerability in two templates
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-08-06 · updated 2026-06-17
- Weakness: CWE-79
Description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. In versions 4.2-milestone-3 through 16.4.7, 16.5.0-rc-1 through 16.10.5 and 17.0.0-rc-1 through 17.2.2, two templates contain reflected XSS vulnerabilities, allowing an attacker to execute malicious JavaScript code in the context of the victim's session by getting the victim to visit an attacker-controlled URL. This permits the attacker to perform arbitrary actions using the permissions of the victim. This issue is fixed in versions 16.4.8, 16.10.6 and 17.3.0-rc-1. To workaround the issue, manually patch the WAR with the same changes as the original patch.
Affected products
- xwiki-platform: from 4.3 before 16.4.8; from 16.5.0 before 16.10.6; from 17.0.0 through 17.2.2; 4.2-milestone3, 16.5.0-rc1 — fixed in 16.10.6, 16.4.8
How to fix
Upgrade to a fixed version: xwiki-platform 16.10.6, 16.4.8. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-platform/commit/e5926a938cbecc8b1eaa48053d8d370cff107cb0
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-m9x4-w7p9-mxhx
- https://jira.xwiki.org/browse/XWIKI-23096
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-m9x4-w7p9-mxhx
Get alerted when CVE-2025-32430 or the next vulnerability affects your stack