What’s Vulnerable › Vulnerabilities

CVE-2025-32432: Craft CMS Code Injection Vulnerability

Description

Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. Starting from version 3.0.0-RC1 to before 3.9.15, 4.0.0-RC1 to before 4.14.15, and 5.0.0-RC1 to before 5.6.17, Craft is vulnerable to remote code execution. This is a high-impact, low-complexity attack vector. This issue has been patched in versions 3.9.15, 4.14.15, and 5.6.17, and is an additional fix for CVE-2023-41892.

Affected products

How to fix

Upgrade to a fixed version: craftcms cms 3.9.15, 4.14.15, 5.6.17. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-32432 or the next vulnerability affects your stack