What’s Vulnerable › Vulnerabilities
CVE-2025-32434: PyTorch: `torch.load` with `weights_only=True` leads to remote code execution
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-18 · updated 2026-06-17
- Weakness: CWE-502
Description
PyTorch is a Python package that provides tensor computation with strong GPU acceleration and deep neural networks built on a tape-based autograd system. In version 2.5.1 and prior, a Remote Command Execution (RCE) vulnerability exists in PyTorch when loading a model using torch.load with weights_only=True. This issue has been patched in version 2.6.0.
Affected products
- PyTorch: before 2.6.0 — fixed in 2.6.0
How to fix
Upgrade to a fixed version: PyTorch 2.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/pytorch/pytorch/security/advisories/GHSA-53q9-r3pm-6pq6
- https://lists.debian.org/debian-lts-announce/2025/12/msg00000.html
Get alerted when CVE-2025-32434 or the next vulnerability affects your stack