What’s Vulnerable › Vulnerabilities
CVE-2025-32440: NetAlertX Vulnerable to Authentication Bypass
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-27 · updated 2026-06-17
- Weakness: CWE-306
Description
NetAlertX is a network, presence scanner and alert framework. Prior to version 25.4.14, it is possible to bypass the authentication mechanism of NetAlertX to update settings without authentication. An attacker can trigger sensitive functions within util.php by sending crafted requests to /index.php. This issue has been patched in version 25.4.14.
Affected products
- NetAlertX: before 25.4.14 — fixed in 25.4.14
How to fix
Upgrade to a fixed version: NetAlertX 25.4.14. Check the vendor advisory for mitigations.
References
- https://github.com/jokob-sk/NetAlertX/releases/tag/v25.4.14
- https://github.com/jokob-sk/NetAlertX/security/advisories/GHSA-h4x5-vr54-vjrx
- https://github.com/jokob-sk/NetAlertX/security/advisories/GHSA-h4x5-vr54-vjrx
Get alerted when CVE-2025-32440 or the next vulnerability affects your stack