What’s Vulnerable › Vulnerabilities
CVE-2025-32442: Fastify vulnerable to invalid content-type parsing, which could lead to validation bypass
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-04-18 · updated 2026-06-17
- Weakness: CWE-1287
Description
Fastify is a fast and low overhead web framework, for Node.js. In versions 5.0.0 to 5.3.0 as well as version 4.29.0, applications that specify different validation strategies for different content types have a possibility to bypass validation by providing a _slightly altered_ content type such as with different casing or altered whitespacing before `;`. This was patched in v5.3.1, but the initial patch did not cover all problems. This has been fully patched in v5.3.2 and v4.29.1. A workaround involves not specifying individual content types in the schema.
Affected products
- fastify: from 5.0.0 before 5.3.2; 4.29.0 — fixed in 5.3.2
How to fix
Upgrade to a fixed version: fastify 5.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/fastify/fastify/commit/436da4c06dfbbb8c24adee3a64de0c51e4f47418
- https://github.com/fastify/fastify/commit/f3d2bcb3963cd570a582e5d39aab01a9ae692fe4
- https://github.com/fastify/fastify/security/advisories/GHSA-mg2h-6x62-wpwc
- https://hackerone.com/reports/3087928
Get alerted when CVE-2025-32442 or the next vulnerability affects your stack