What’s Vulnerable › Vulnerabilities
CVE-2025-32462
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-30 · updated 2026-07-14
- Weakness: CWE-863
Description
Sudo before 1.9.17p1, when used with a sudoers file that specifies a host that is neither the current host nor ALL, allows listed users to execute commands on unintended machines.
Affected products
- sudo: before 1.9.17; 1.9.17 — fixed in 1.9.17
How to fix
Upgrade to a fixed version: sudo 1.9.17. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/cve-2025-32462
- https://bugs.gentoo.org/show_bug.cgi?id=CVE-2025-32462
- https://explore.alas.aws.amazon.com/CVE-2025-32462.html
- https://lists.debian.org/debian-security-announce/2025/msg00118.html
- https://security-tracker.debian.org/tracker/CVE-2025-32462
- https://ubuntu.com/security/notices/USN-7604-1
- https://www.openwall.com/lists/oss-security/2025/06/30/2
- https://www.secpod.com/blog/sudo-lpe-vulnerabilities-resolved-what-you-need-to-know-about-cve-2025-32462-and-cve-2025-32463/
- https://www.stratascale.com/vulnerability-alert-CVE-2025-32462-sudo-host
- https://www.sudo.ws/releases/changelog/
- https://www.sudo.ws/security/advisories/
- https://www.sudo.ws/security/advisories/host_any/
Get alerted when CVE-2025-32462 or the next vulnerability affects your stack