What’s Vulnerable › Vulnerabilities
CVE-2025-3248: Langflow Missing Authentication Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2025-05-05
- EPSS: 100.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-04-07 · updated 2026-10-08
- Weakness: CWE-306
Description
Langflow versions prior to 1.3.0 are susceptible to code injection in the /api/v1/validate/code endpoint. A remote and unauthenticated attacker can send crafted HTTP requests to execute arbitrary code.
Affected products
- IBM Langflow OSS: before 1.3.0 — fixed in 1.3.0
How to fix
Upgrade to a fixed version: IBM Langflow OSS 1.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/langflow-ai/langflow/pull/6911
- https://github.com/langflow-ai/langflow/releases/tag/1.3.0
- https://www.horizon3.ai/attack-research/disclosures/unsafe-at-any-speed-abusing-python-exec-for-unauth-rce-in-langflow-ai/
- https://www.vulncheck.com/advisories/langflow-unauthenticated-rce
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-3248
Get alerted when CVE-2025-3248 or the next vulnerability affects your stack