What’s Vulnerable › Vulnerabilities
CVE-2025-32698: LogPager.php: Restriction enforcer functions do not correctly enforce suppression restrictions
- Severity: low (CVSS 2.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-10 · updated 2026-06-17
- Weakness: CWE-200
Description
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/logging/LogPager.Php. This issue affects MediaWiki: before 1.39.12, 1.42.6, 1.43.1.
Affected products
- Wikimedia Foundation MediaWiki: before 1.39.12, 1.42.6, 1.43.1 — fixed in 1.42.6, 1.43.1, 1.39.12
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.42.6, 1.43.1, 1.39.12. Check the vendor advisory for mitigations.
References
- https://phabricator.wikimedia.org/T385958
- https://lists.debian.org/debian-lts-announce/2025/07/msg00012.html
Get alerted when CVE-2025-32698 or the next vulnerability affects your stack