What’s Vulnerable › Vulnerabilities
CVE-2025-32700: AbuseFilter log interfaces expose global private and hidden filters when central DB is not available
- Severity: low (CVSS 2.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-10 · updated 2026-06-17
- Weakness: CWE-200
Description
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Wikimedia Foundation AbuseFilter. This vulnerability is associated with program files includes/Api/QueryAbuseLog.Php, includes/Pager/AbuseLogPager.Php, includes/Special/SpecialAbuseLog.Php, includes/View/AbuseFilterViewExamine.Php. This issue affects AbuseFilter: from >= 1.43.0 before 1.43.1.
Affected products
- Wikimedia Foundation MediaWiki: from >= 1.43.0 before 1.43.1 — fixed in 1.43.1
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.43.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-32700 or the next vulnerability affects your stack