What’s Vulnerable › Vulnerabilities
CVE-2025-32777: Volcano Scheduler Denial of Service via Unbounded Response from Elastic Service/extender Plugin
- Severity: high (CVSS 8.2 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-30 · updated 2026-06-17
- Weakness: CWE-770
Description
Volcano is a Kubernetes-native batch scheduling system. Prior to versions 1.11.2, 1.10.2, 1.9.1, 1.11.0-network-topology-preview.3, and 1.12.0-alpha.2, attacker compromise of either the Elastic service or the extender plugin can cause denial of service of the scheduler. This is a privilege escalation, because Volcano users may run their Elastic service and extender plugins in separate pods or nodes from the scheduler. In the Kubernetes security model, node isolation is a security boundary, and as such an attacker is able to cross that boundary in Volcano's case if they have compromised either the vulnerable services or the pod/node in which they are deployed. The scheduler will become unavailable to other users and workloads in the cluster. The scheduler will either crash with an unrecoverable OOM panic or freeze while consuming excessive amounts of memory. This issue has been patched in versions 1.11.2, 1.10.2, 1.9.1, 1.11.0-network-topology-preview.3, and 1.12.0-alpha.2.
Affected products
- volcano-sh volcano: from 1.11.0, < 1.11.2; from 1.10.0-alpha.0, < 1.10.2; before 1.9.1; from 1.11.0-network-topology-preview.0, < 1.11.0-network-topology-preview.3; from 1.12.0-alpha.0, < 1.12.0-alpha.2
References
- https://github.com/volcano-sh/volcano/releases/tag/v1.10.2
- https://github.com/volcano-sh/volcano/releases/tag/v1.11.0-network-topology-preview.3
- https://github.com/volcano-sh/volcano/releases/tag/v1.11.2
- https://github.com/volcano-sh/volcano/releases/tag/v1.12.0-alpha.2
- https://github.com/volcano-sh/volcano/releases/tag/v1.9.1
- https://github.com/volcano-sh/volcano/security/advisories/GHSA-hg79-fw4p-25p8
Get alerted when CVE-2025-32777 or the next vulnerability affects your stack