What’s Vulnerable › Vulnerabilities
CVE-2025-32785: Pi-hole Admin Interface vulnerable to persistent XSS on Subscribed lists group management (Adress Field)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-10-27 · updated 2026-10-08
- Weakness: CWE-79
Description
Pi-hole Admin Interface is a web interface for managing Pi-hole, a network-level advertisement and internet tracker blocking application. Pi-hole Admin Interface versions prior to 6.3 are vulnerable to cross-site scripting (XSS) via the Address field in the Subscribed Lists group management section. An authenticated user can inject malicious JavaScript by adding a payload to the Address field when creating or editing a list entry. The vulnerability is triggered when another user navigates to the Tools section and performs a gravity database update. The Address field does not properly sanitize input, allowing special characters and script tags to bypass validation. This has been patched in version 6.3.
Affected products
- pi-hole web: before 6.3 — fixed in 6.3
How to fix
Upgrade to a fixed version: pi-hole web 6.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-32785 or the next vulnerability affects your stack