What’s Vulnerable › Vulnerabilities
CVE-2025-32794: OpenEMR Stored XSS via Patient Name Field in Procedure Orders
- Severity: high (CVSS 7.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-23 · updated 2026-06-17
- Weakness: CWE-79
Description
OpenEMR is a free and open source electronic health records and medical practice management application. A stored cross-site scripting (XSS) vulnerability in versions prior to 7.0.3.4 allows any authenticated user with patient creation privileges to inject arbitrary JavaScript code into the system by entering malicious payloads in the First and Last Name fields during patient registration. This code is later executed when viewing the patient's encounter under Orders → Procedure Orders. Version 7.0.3.4 contains a patch for the issue.
Affected products
- openemr: before 7.0.3.4 — fixed in 7.0.3.4
How to fix
Upgrade to a fixed version: openemr 7.0.3.4. Check the vendor advisory for mitigations.
References
- https://github.com/openemr/openemr/security/advisories/GHSA-3c27-2m7h-f7rx
- https://github.com/openemr/openemr/security/advisories/GHSA-3c27-2m7h-f7rx
Get alerted when CVE-2025-32794 or the next vulnerability affects your stack