What’s Vulnerable › Vulnerabilities
CVE-2025-32798: Conda-build Allows Arbitrary Code Execution via Malicious Recipe Selectors
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-16 · updated 2026-06-17
- Weakness: CWE-94
Description
Conda-build contains commands and tools to build conda packages. Prior to version 25.4.0, the conda-build recipe processing logic has been found to be vulnerable to arbitrary code execution due to unsafe evaluation of recipe selectors. Currently, conda-build uses the eval function to process embedded selectors in meta.yaml files. This approach evaluates user-defined expressions without proper sanitization, which allows arbitrary code to be executed during the build process. As a result, the integrity of the build environment is compromised, and unauthorized commands or file operations may be performed. The vulnerability stems from the inherent risk of using eval() on untrusted input in a context intended to control dynamic build configurations. By directly interpreting selector expressions, conda-build creates a potential execution pathway for malicious code, violating security assumptions. This issue has been patched in version 25.4.0.
Affected products
- conda-build: before 25.4.0 — fixed in 25.4.0
How to fix
Upgrade to a fixed version: conda-build 25.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/conda/conda-build/blob/834448b995eee02cf1c2e7ca97bcfa9affc77ee5/conda_build/metadata.py
- https://github.com/conda/conda-build/commit/3d87213b840774a24ab1733664d2b36664233754
- https://github.com/conda/conda-build/security/advisories/GHSA-6cc8-c3c9-3rgr
- https://github.com/conda/conda-build/security/advisories/GHSA-6cc8-c3c9-3rgr
Get alerted when CVE-2025-32798 or the next vulnerability affects your stack