What’s Vulnerable › Vulnerabilities
CVE-2025-32800: Conda-build vulnerable to supply chain attack vector due to pyproject.toml referring to dependencies not present in PyPI
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-16 · updated 2026-06-17
- Weakness: CWE-1357
Description
Conda-build contains commands and tools to build conda packages. Prior to version 25.3.0, the pyproject.toml lists conda-index as a Python dependency. This package is not published in PyPI. An attacker could claim this namespace and upload arbitrary (malicious) code to the package, and then exploit pip install commands by injecting the malicious dependency in the solve. This issue has been fixed in version 25.3.0. A workaround involves using --no-deps for pip install-ing the project from the repository.
Affected products
- conda-build: before 25.3.0 — fixed in 25.3.0
How to fix
Upgrade to a fixed version: conda-build 25.3.0. Check the vendor advisory for mitigations.
References
- https://drive.google.com/file/d/18qe97zxcpTn2l84187A9meGCi2Wg-n_Y/view
- https://github.com/conda/conda-build/commit/f5a6aeef0d5d6940b8c2a88796910dc7476a62bb
- https://github.com/conda/conda-build/security/advisories/GHSA-83gh-p93g-cwgx
Get alerted when CVE-2025-32800 or the next vulnerability affects your stack