What’s Vulnerable › Vulnerabilities
CVE-2025-32911: Libsoup: double free on soup_message_headers_get_content_disposition() through "soup-message-headers.c" via "params" ghashtable value
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-15 · updated 2026-11-01
- Weakness: CWE-590
Description
A use-after-free type vulnerability was found in libsoup, in the soup_message_headers_get_content_disposition() function. This flaw allows a malicious HTTP client to cause memory corruption in the libsoup server.
Affected products
- Libsoup: before 3.6.3 — fixed in 3.6.3
- Red Hat Enterprise Linux 7 Extended Lifecycle Support: all versions — fixed in 0:2.62.2-9.el7_9
- Red Hat Enterprise Linux 8: all versions — fixed in 0:2.62.3-8.el8_10
- Red Hat Enterprise Linux 8.2 Advanced Update Support: all versions — fixed in 0:2.62.3-1.el8_2.4
- Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Support: all versions — fixed in 0:2.62.3-2.el8_4.4
- Red Hat Enterprise Linux 8.4 Telecommunications Update Service: all versions — fixed in 0:2.62.3-2.el8_4.4
- Red Hat Enterprise Linux 8.4 Update Services for SAP Solutions: all versions — fixed in 0:2.62.3-2.el8_4.4
- Red Hat Enterprise Linux 8.6 Advanced Mission Critical Update Support: all versions — fixed in 0:2.62.3-2.el8_6.4
- Red Hat Enterprise Linux 8.6 Telecommunications Update Service: all versions — fixed in 0:2.62.3-2.el8_6.4
- Red Hat Enterprise Linux 8.6 Update Services for SAP Solutions: all versions — fixed in 0:2.62.3-2.el8_6.4
- Red Hat Enterprise Linux 8.8 Extended Update Support: all versions — fixed in 0:2.62.3-3.el8_8.4
- Red Hat Enterprise Linux 9: all versions — fixed in 0:2.72.0-10.el9_6.1
- Red Hat Enterprise Linux 9.0 Update Services for SAP Solutions: all versions — fixed in 0:2.72.0-8.el9_0.4
- Red Hat Enterprise Linux 9.2 Extended Update Support: all versions — fixed in 0:2.72.0-8.el9_2.4
- Red Hat Enterprise Linux 9.4 Extended Update Support: all versions — fixed in 0:2.72.0-8.el9_4.4
How to fix
Upgrade to a fixed version: Libsoup 3.6.3; Red Hat Enterprise Linux 7 Extended Lifecycle Support 0:2.62.2-9.el7_9; Red Hat Enterprise Linux 8 0:2.62.3-8.el8_10; Red Hat Enterprise Linux 8.2 Advanced Update Support 0:2.62.3-1.el8_2.4; Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Support 0:2.62.3-2.el8_4.4; Red Hat Enterprise Linux 8.4 Telecommunications Update Service 0:2.62.3-2.el8_4.4; Red Hat Enterprise Linux 8.4 Update Services for SAP Solutions 0:2.62.3-2.el8_4.4; Red Hat Enterprise Linux 8.6 Advanced Mission Critical Update Support 0:2.62.3-2.el8_6.4; Red Hat Enterprise Linux 8.6 Telecommunications Update Service 0:2.62.3-2.el8_6.4; Red Hat Enterprise Linux 8.6 Update Services for SAP Solutions 0:2.62.3-2.el8_6.4; Red Hat Enterprise Linux 8.8 Extended Update Support 0:2.62.3-3.el8_8.4; Red Hat Enterprise Linux 9 0:2.72.0-10.el9_6.1. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2025:21657
- https://access.redhat.com/errata/RHSA-2025:4439
- https://access.redhat.com/errata/RHSA-2025:4440
- https://access.redhat.com/errata/RHSA-2025:4508
- https://access.redhat.com/errata/RHSA-2025:4538
- https://access.redhat.com/errata/RHSA-2025:4560
- https://access.redhat.com/errata/RHSA-2025:4568
- https://access.redhat.com/errata/RHSA-2025:4609
- https://access.redhat.com/errata/RHSA-2025:4624
- https://access.redhat.com/errata/RHSA-2025:7436
- https://access.redhat.com/errata/RHSA-2025:8292
- https://access.redhat.com/security/cve/CVE-2025-32911
Get alerted when CVE-2025-32911 or the next vulnerability affects your stack