What’s Vulnerable › Vulnerabilities
CVE-2025-32914: Libsoup: oob read on libsoup through function "soup_multipart_new_from_message" in soup-multipart.c leads to crash or exit of process
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-14 · updated 2026-11-01
- Weakness: CWE-125
Description
A flaw was found in libsoup, where the soup_multipart_new_from_message() function is vulnerable to an out-of-bounds read. This flaw allows a malicious HTTP client to induce the libsoup server to read out of bounds.
Affected products
- Libsoup: before 3.6.5 — fixed in 3.6.5
- Red Hat Enterprise Linux 10: all versions — fixed in 0:3.6.5-3.el10_0
- Red Hat Enterprise Linux 7 Extended Lifecycle Support: all versions — fixed in 0:2.62.2-9.el7_9
- Red Hat Enterprise Linux 8: all versions — fixed in 0:2.62.3-9.el8_10
- Red Hat Enterprise Linux 8.2 Advanced Update Support: all versions — fixed in 0:2.62.3-1.el8_2.5
- Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Support: all versions — fixed in 0:2.62.3-2.el8_4.5
- Red Hat Enterprise Linux 8.6 Advanced Mission Critical Update Support: all versions — fixed in 0:2.62.3-2.el8_6.5
- Red Hat Enterprise Linux 8.6 Telecommunications Update Service: all versions — fixed in 0:2.62.3-2.el8_6.5
- Red Hat Enterprise Linux 8.6 Update Services for SAP Solutions: all versions — fixed in 0:2.62.3-2.el8_6.5
- Red Hat Enterprise Linux 8.8 Extended Update Support: all versions — fixed in 0:2.62.3-3.el8_8.5
- Red Hat Enterprise Linux 9: all versions — fixed in 0:2.72.0-10.el9_6.2
- Red Hat Enterprise Linux 9.0 Update Services for SAP Solutions: all versions — fixed in 0:2.72.0-8.el9_0.5
- Red Hat Enterprise Linux 9.2 Extended Update Support: all versions — fixed in 0:2.72.0-8.el9_2.5
- Red Hat Enterprise Linux 9.4 Extended Update Support: all versions — fixed in 0:2.72.0-8.el9_4.5
How to fix
Upgrade to a fixed version: Libsoup 3.6.5; Red Hat Enterprise Linux 10 0:3.6.5-3.el10_0; Red Hat Enterprise Linux 7 Extended Lifecycle Support 0:2.62.2-9.el7_9; Red Hat Enterprise Linux 8 0:2.62.3-9.el8_10; Red Hat Enterprise Linux 8.2 Advanced Update Support 0:2.62.3-1.el8_2.5; Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Support 0:2.62.3-2.el8_4.5; Red Hat Enterprise Linux 8.6 Advanced Mission Critical Update Support 0:2.62.3-2.el8_6.5; Red Hat Enterprise Linux 8.6 Telecommunications Update Service 0:2.62.3-2.el8_6.5; Red Hat Enterprise Linux 8.6 Update Services for SAP Solutions 0:2.62.3-2.el8_6.5; Red Hat Enterprise Linux 8.8 Extended Update Support 0:2.62.3-3.el8_8.5; Red Hat Enterprise Linux 9 0:2.72.0-10.el9_6.2; Red Hat Enterprise Linux 9.0 Update Services for SAP Solutions 0:2.72.0-8.el9_0.5. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2025:21657
- https://access.redhat.com/errata/RHSA-2025:7505
- https://access.redhat.com/errata/RHSA-2025:8126
- https://access.redhat.com/errata/RHSA-2025:8132
- https://access.redhat.com/errata/RHSA-2025:8139
- https://access.redhat.com/errata/RHSA-2025:8140
- https://access.redhat.com/errata/RHSA-2025:8252
- https://access.redhat.com/errata/RHSA-2025:8480
- https://access.redhat.com/errata/RHSA-2025:8481
- https://access.redhat.com/errata/RHSA-2025:8482
- https://access.redhat.com/errata/RHSA-2025:8663
- https://access.redhat.com/security/cve/CVE-2025-32914
Get alerted when CVE-2025-32914 or the next vulnerability affects your stack