What’s Vulnerable › Vulnerabilities
CVE-2025-32944: PeerTube User Import Authenticated Persistent Denial of Service
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-04-15 · updated 2026-06-17
- Weakness: CWE-248
Description
The vulnerability allows any authenticated user to cause the PeerTube server to stop functioning in a persistent manner. If user import is enabled (which is the default setting), any registered user can upload an archive for importing. The code uses the yauzl library for reading the archive. If the yauzl library encounters a filename that is considered illegal, it raises an exception that is uncaught by PeerTube, leading to a crash which repeats infinitely on startup.
Affected products
- chocobozzz/peertube: before 7.1.1 — fixed in 7.1.1
How to fix
Upgrade to a fixed version: chocobozzz/peertube 7.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/Chocobozzz/PeerTube/releases/tag/v7.1.1
- https://research.jfrog.com/vulnerabilities/peertube-archive-persistent-dos/
Get alerted when CVE-2025-32944 or the next vulnerability affects your stack