What’s Vulnerable › Vulnerabilities
CVE-2025-32968: org.xwiki.platform:xwiki-platform-oldcore allows SQL injection in short form select requests through the script query API
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-04-23 · updated 2026-06-17
- Weakness: CWE-89
Description
XWiki is a generic wiki platform. In versions starting from 1.6-milestone-1 to before 15.10.16, 16.4.6, and 16.10.1, it is possible for a user with SCRIPT right to escape from the HQL execution context and perform a blind SQL injection to execute arbitrary SQL statements on the database backend. Depending on the used database backend, the attacker may be able to not only obtain confidential information such as password hashes from the database, but also execute UPDATE/INSERT/DELETE queries. This issue has been patched in versions 16.10.1, 16.4.6 and 15.10.16. There is no known workaround, other than upgrading XWiki. The protection added to this REST API is the same as the one used to validate complete select queries, making it more consistent. However, while the script API always had this protection for complete queries, it's important to note that it's a very strict protection and some valid, but complex, queries might suddenly require the author to have programming right.
Affected products
- xwiki-platform: from 1.6 before 15.10.16; from 16.0.0 before 16.4.6; from 16.5.0 through 16.10.1 — fixed in 15.10.16, 16.4.6
How to fix
Upgrade to a fixed version: xwiki-platform 15.10.16, 16.4.6. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-g9jj-75mx-wjcx
- https://jira.xwiki.org/browse/XWIKI-22718
Get alerted when CVE-2025-32968 or the next vulnerability affects your stack