What’s Vulnerable › Vulnerabilities
CVE-2025-32971: XWiki Solr script service doesn't take dropped programming right into account
- Severity: low (CVSS 3.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-04-30 · updated 2026-06-17
- Weakness: CWE-863
Description
XWiki is a generic wiki platform. In versions starting from 4.5.1 to before 15.10.13, from 16.0.0-rc-1 to before 16.4.4, and from 16.5.0-rc-1 to before 16.8.0-rc-1, the Solr script service doesn't take dropped programming rights into account. The Solr script service that is accessible in XWiki's scripting API normally requires programming rights to be called. Due to using the wrong API for checking rights, it doesn't take the fact into account that programming rights might have been dropped by calling `$xcontext.dropPermissions()`. If some code relies on this for the safety of executing Velocity code with the wrong author context, this could allow a user with script rights to either cause a high load by indexing documents or to temporarily remove documents from the search index. This issue has been patched in versions 15.10.13, 16.4.4, and 16.8.0-rc-1.
Affected products
- xwiki-platform: from 4.5.1 before 15.10.13; from 16.0.0 before 16.4.4; from 16.5.0 before 16.8.0 — fixed in 15.10.13, 16.4.4, 16.8.0
How to fix
Upgrade to a fixed version: xwiki-platform 15.10.13, 16.4.4, 16.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-platform/commit/6570f40f976aec82baf388b5239d1412cab238c9
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-987p-r3jc-8c8v
- https://jira.xwiki.org/browse/XWIKI-22474
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-987p-r3jc-8c8v
- https://jira.xwiki.org/browse/XWIKI-22474
Get alerted when CVE-2025-32971 or the next vulnerability affects your stack