What’s Vulnerable › Vulnerabilities

CVE-2025-32972: The lesscss script service allows cache clearing without programming right

Description

XWiki is a generic wiki platform. In versions starting from 6.1-milestone-1 to before 15.10.12, from 16.0.0-rc-1 to before 16.4.3, and from 16.5.0-rc-1 to before 16.8.0-rc-1, the script API of the LESS compiler in XWiki is incorrectly checking for rights when calling the cache cleaning API, making it possible to clean the cache without having programming right. The only impact of this is a slowdown in XWiki execution as the caches are re-filled. As this vulnerability requires script right to exploit, and script right already allows unlimited execution of scripts, the additional impact due to this vulnerability is low. This issue has been patched in versions 15.10.12, 16.4.3, and 16.8.0-rc-1.

Affected products

How to fix

Upgrade to a fixed version: xwiki-platform 15.10.12, 16.4.3, 16.8.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-32972 or the next vulnerability affects your stack