What’s Vulnerable › Vulnerabilities
CVE-2025-32974: org.xwiki.platform:xwiki-platform-security-requiredrights-default required rights analysis doesn't consider TextAreas with default content type
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-30 · updated 2026-06-17
- Weakness: CWE-116
Description
XWiki is a generic wiki platform. In versions starting from 15.9-rc-1 to before 15.10.8 and from 16.0.0-rc-1 to before 16.2.0, the required rights analysis doesn't consider TextAreas with default content type. When editing a page, XWiki warns since version 15.9 when there is content on the page like a script macro that would gain more rights due to the editing. This analysis doesn't consider certain kinds of properties, allowing a user to put malicious scripts in there that will be executed after a user with script, admin, or programming rights edited the page. Such a malicious script could impact the confidentiality, integrity and availability of the whole XWiki installation. This issue has been patched in versions 15.10.8 and 16.2.0.
Affected products
- xwiki-platform: from 15.9 before 15.10.8; from 16.0.0 before 16.2.0 — fixed in 15.10.8, 16.2.0
How to fix
Upgrade to a fixed version: xwiki-platform 15.10.8, 16.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-platform/commit/153dbfa2ef1a7a0a644fe3f889684c6a8738c5fc
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-mvgm-3rw2-7j4r
- https://jira.xwiki.org/browse/XWIKI-22002
- https://jira.xwiki.org/browse/XWIKI-22002
Get alerted when CVE-2025-32974 or the next vulnerability affects your stack