What’s Vulnerable › Vulnerabilities
CVE-2025-32996
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-15 · updated 2026-06-17
- Weakness: CWE-670
Description
In http-proxy-middleware before 2.0.8 and 3.x before 3.0.4, writeBody can be called twice because "else if" is not used.
Affected products
- chimurai http-proxy-middleware: before 2.0.8; from 3.0.0 before 3.0.4 — fixed in 2.0.8, 3.0.4
How to fix
Upgrade to a fixed version: chimurai http-proxy-middleware 2.0.8, 3.0.4. Check the vendor advisory for mitigations.
References
- https://github.com/chimurai/http-proxy-middleware/commit/020976044d113fc0bcbbaf995e91d05e2829a145
- https://github.com/chimurai/http-proxy-middleware/pull/1089
- https://github.com/chimurai/http-proxy-middleware/releases/tag/v2.0.8
- https://github.com/chimurai/http-proxy-middleware/releases/tag/v3.0.4
Get alerted when CVE-2025-32996 or the next vulnerability affects your stack