What’s Vulnerable › Vulnerabilities
CVE-2025-33042: Apache Avro Java SDK: Code injection on Java generated code
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-13 · updated 2026-06-17
- Weakness: CWE-94
Description
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Avro Java SDK when generating specific records from untrusted Avro schemas. This issue affects Apache Avro Java SDK: all versions through 1.11.4 and version 1.12.0. Users are recommended to upgrade to version 1.12.1 or 1.11.5, which fix the issue.
Affected products
- Apache Software Foundation Apache Avro: before 1.11.5; 1.12.0, 1.12.0-rc0, 1.12.0-rc1 — fixed in 1.11.5
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Avro 1.11.5. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/fy88wmgf1lj9479vrpt12cv8x73lroj1
- http://www.openwall.com/lists/oss-security/2026/02/12/2
Get alerted when CVE-2025-33042 or the next vulnerability affects your stack